Forums MHS

Forums français autour de Windows Home Server | Par Mon Home Server

Vous n'êtes pas identifié.

Annonce

Veuillez prendre connaissance de ces quelques règles avant la publication de messages :
- Le langage SMS et l'utilisation abusive des majuscules sont à éviter ;
- Aucun lien vers des sites illégaux et de téléchargement ne seront tolérés ;
Les modérateurs se gardent le droit de bannir les auteurs ne respectant pas ces règles.

Cet espace est aussi le vôtre, respectez-le.
L'administrateur se garde tous les droits pour assurer la qualité des échanges.

Respectez la langue française.


Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/clients/9b3714d5ebccce428d36c2e50dd13885/forums.monhomeserver.fr/include/parser.php on line 348

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/clients/9b3714d5ebccce428d36c2e50dd13885/forums.monhomeserver.fr/include/parser.php on line 349

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/clients/9b3714d5ebccce428d36c2e50dd13885/forums.monhomeserver.fr/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/clients/9b3714d5ebccce428d36c2e50dd13885/forums.monhomeserver.fr/include/parser.php on line 333

Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /home/clients/9b3714d5ebccce428d36c2e50dd13885/forums.monhomeserver.fr/include/parser.php on line 406

#1 28-05-2018 12:17:49

MichaelSmith
Nouveau membre
Date d'inscription: 17-05-2018
Messages: 5

arduino to PC serial port problems

Hello,

I've just started playing around with a Diecimila I bought a while ago. I've been able to run simple examples with no trouble. I added some some simple Serial.print statements to the Blink program and displayed them using the serial port monitor.Then I broke out a serial cable and plugged Tx into pin 0, Rx into pin 1 and Signal Ground into one of the Diecimila ground connections. I connect this to another computer and run a terminal program, set the baud rate to match the Serial.begin statement and power up the Arduino.All I see is garbage, like the baud rate is set wrong.I've tried all sorts of permutations, different baud rates, character make-up, etc. Verified the cable by connecting to another PC, etc. I also tried using the SoftwareSerial library and different pins. I'm an old hand at serial comms but this has stumped me for more than a day.Am I incorrect in thinking Signal Ground should connect to the Diecimila ground ? Is there some other trick I have missed?

Please help.

I didn't find the right solution from the Internet.

References:-
https://forums.adafruit.com/viewtopic.p … mp;p=46234
Explainer video production agency

Thanks

Hors ligne

 
Ces forums font parti du blog Mon Home Server | Twitter | Facebook | Contact (pas du support par mail).

Pied de page des forums